
 

 

  



 

1. Introduction 

MIDI to DMX controller (MTD-1024) can convert MIDI messages to DMX messages. Supports MIDI 

Note/CC/After Touch MIDI messages, can map the value of MIDI messages to DMX channels, and can configure 

up to 1024 DMX channels. MTD-1024 can be used for MIDI performance, DMX lighting control scene. 

2. Appearance 

 

❶ USB DEVICE: Product power supply port, power supply voltage 5VDC, current 1A, with USB MIDI function, it 

can also be connected to computers/mobile phones and other terminals to receive MIDI messages. 

❷ MIDI IN: MIDI DIN input port, use a five-pin MIDI cable to connect an instrument with MIDI OUT. 

❸ DMX OUT1: DMX output port, connect the device with DMX IN port through 3Pin XLR cable. 

❹ DMX OUT2: DMX output port, connect the device with DMX IN port through 3Pin XLR cable. 

❺ Display Screen: OLED display screen, showing the working status of MTD-1024. 

❻ Knob: Knob with button function, through rotation and click, configure the working of MTD-1024. 

3. Product Parameters 

Name Description 

Model MTD-1024 

Size (L x W x H) 88*79*52mm 

Weight 180g  

Supply Voltage 5VDC 

Supply Current  

USB MIDI Compatibility Standard USB MIDI device, compliant with USB class, plug and play. 

MIDI IN Compatibility 
Built-in high-speed optical isolator, compatible with all MIDI five-pin output 

interfaces. 

DMX Channel 
Support 1024 channel configuration, each DMX output port has 512 channels. 

DMX OUT1: 1~512     DMX OUT2: 513~1024. 



 

4. Steps for usage 

4.1. Power supply 

 Supply power to the product through the USB port, support 5VDC/1A power supply input. 

4.2. Connect 

 Connect MIDI five-pin instrument: Connect the MIDI IN of the product to the MIDI OUT of the instrument 

through a MIDI five-pin cable. 

 Connect to computer/mobile phone: If playing MIDI messages via software, it can be connected to a 

computer/mobile phone via USB. 

(Note: The mobile phone needs to have OTG function, and different mobile phone interfaces need to be 

connected through an OTG converter.) 

 Connect DMX device: Connect DMX OUT1 and DMX OUT2 to the input port of DMX devices  through 3Pin 

XLR cable. 

 

  



 

4.3. Configure MIDI to DMX 

 Click the knob to select SN / DMX / Sta / Ctl / CH / En / Fix / Fad / Tog, and rotate the knob to set parameters. 

After setting, the received MIDI message value 0~127 will output the corresponding DMX channel value 

0~255, that is, DMX value = MIDI value x 2.01 (the coefficient defaults to 2.01 and can be changed). As 

shown in the table: 

SN    DMX    Sta    Ctl    CH    En   Fix   Fad   Tog

1

2

3

2 Note 0 All 0 0 0 0

 

Display Name Description 

SN Serial Number 
Display and configure the parameters of the current serial number. 

Parameter range: 1~1024 

DMX DMX Channel 

Configure the DMX channel. 

Parameter range: 1~1024. 

DMX OUT1: 1~512     

DMX OUT2: 513~1024.(The output is DMX channel 1~512) 

Sta MIDI Status 

Configure the MIDI status byte. 

Parameter range: Note/AT/CC. 

Note: MIDI Notes, DMX channel value = MIDI note velocity value x2.01. 

CC: MIDI Continuous Controller, DMX channel value = MIDI controller value x 

2.01. 

AT: MIDI After Touch, DMX channel value = MIDI AfterTouch value x2.01. 

Ctl 

MIDI 

Controller/Note 

Number 

Configure MIDI controller/note numbers. 

Parameter range: 0~127. 

When Sta = Note/AT, Ctl is the note number. 

When Sta = CC, Ctl is the controller number. 

CH MIDI Channel 

Configure MIDI channels for MIDI messages. 

Parameter range: All, 1~16, default All. 

All: Means to respond to messages on all MIDI channels. 

En Enable switch 
Configure to enable the parameters of this serial number (SN). 

1: enable.   0: disable enable. 

Fix Fixed DMX Value 

Set the fixed output DMX value. When a MIDI message is received, DMX 

outputs a fixed value. 

Parameter range: 0~255; 

0: Turn off fixed conversion.      1~255: Output DMX value; 

Fad DMX Fade out  

After the fade-out function is turned on, when the DMX channel output is turned 

off, the DMX value gradually decreases to 0. 

Parameter range: 0~50 

0: Turn off gradient. 

1~50: Set the fade-out speed. The larger the value, the faster the fade-out. 

Tog DMX Toggle 

After turning on the toggle function, the DMX output will be turned on when the 

MIDI value is received for the first time, and the DMX output will be turned off 

when the MIDI value is received for the second time. 

1: enable.    0: Disable enable. 



 

Note: ①A new serial number will only be added after the existing serial number has been configured. 

②Select a serial number, press and hold the knob for 2 seconds, and the configuration content of the 

serial number will be cleared. 

 Other operations 

Name Description 

System Settings 

Rotate the knob to the last serial number, press and hold the knob for 2 seconds to 

enter the DMX Break/DMX After Break/Factory Reset system setting. 

DMX AfterBreak

Factory Reset

DMX Break
SN    DMX    Sta    Ctl    CH    En

4

2

3

 

DMX Break Time 

Turn the knob, click DMX Break, enter the DMX Break time setting, turn the knob to set 

the DMX Break time, click the knob to save. 

Parameter range: 100~1000us, default 100us. 

100usDMX AfterBreak

Factory Reset

DMX Break

 

DMX After Break Time 

Turn the knob, click DMX After Break, enter DMX After Break time setting, turn the 

knob to set DMX Break time, click the knob to save. 

Parameter range: 50~510us, default 100us. 

50usDMX AfterBreak

Factory Reset

DMX Break

 

Save To Backup 

Rotate the knob and click Save To Backup to back up the current MIDI to DMX 

configuration to prevent accidental touch. 

Back up Current 

Settings?
Save To Backup

Use Backup

Factory Reset

Yes No
 

Use Backup 

Turn the knob and click Use Backup to use the backed-up MIDI to DMX configuration. 

Use Backup 

Setting?
Use Backup

Coefficient

Save To Backup

Yes No
 

Coefficient 

Rotate the knob and click Coefficient to set the MIDI to DMX conversion coefficient, that 

is, DMX value = MIDI value x Coefficient. 

Parameter range: 2/2.01/3/4/5, default 2.01. 



 

2.01
Coefficient

Use Backup
MIDI To DMX

Coefficient

 

Factory Reset 

Turn the knob, click Factory Reset, enter the factory reset interface, turn the knob to 

select Yes/No, click the knob. 

Factory Reset?

Yes No
 

Enter Firmware 

Upgrade 

Press and hold the knob, then power on the product, the product will enter the upgrade 

mode. (Note: Please pay attention to the official website notification, if there is a firmware 

update.) 

Upgrade...

 

Note: In order to be compatible with more DMX receivers, MTD-1024 can set the DMX Break time, so that 

some slower DMX receivers can also be used normally. If you find that your DMX receiver receives wrong 

DMX signal, or does not receive DMX signal, please try to adjust DMX Break time and After Break time. 

 For example: 

If you want to control the DMX channel 1 with C4, MTD-1024 configuration is as follows: 

SN    DMX    Sta    Ctl    CH    En

1

2

3

1 Note 60 All 1

 

Note: DMX devices often require multiple DMX channels to control, please refer to the instruction manual 

configuration of the DMX device. 

  



 

Note Name & MIDI Note Number Table  

Note Name                   A0 A#1/Bb1 B0 

MIDI Note Number                   21 22 23 

Note Name C1 C#1/Db1 D1 D#1/Eb1 E1 F1 F#1/Gb1 G1 G#1/Ab1 A1 A#1/Bb1 B1 

MIDI Note Number 24 25 26 27 28 29 30 31 32 33 34 35 

Note Name C2 C#2/Db2 D2 D#2/Eb2 E2 F2 F#2/Gb2 G2 G#2/Ab2 A2 A#2/Bb2 B2 

MIDI Note Number 36 37 38 39 40 41 42 43 44 45 46 47 

Note Name C3 C#3/Db3 D3 D#3/Eb3 E3 F3 F#3/Gb3 G3 G#3/Ab3 A1 A#3/Bb3 B3 

MIDI Note Number 48 49 50 51 52 53 54 55 56 57 58 59 

Note Name C4 C#4/Db4 D4 D#4/Eb4 E4 F4 F#4/Gb4 G4 G#4/Ab4 A4 A#4/Bb4 B4 

MIDI Note Number 60 61 62 63 64 65 66 67 68 69 70 71 

Note Name C5 C#5/Db5 D5 D#5/Eb5 E5 F5 F#5/Gb5 G5 G#5/Ab5 A1 A#5/Bb5 B5 

MIDI Note Number 72 73 74 75 76 77 78 79 80 81 82 83 

Note Name C6 C#6/Db6 D6 D#6/Eb6 E6 F6 F#6/Gb6 G6 G#6/Ab6 A6 A#6/Bb6 B6 

MIDI Note Number 84 85 86 87 88 89 90 91 92 93 94 95 

Note Name C7 C#7/Db7 D7 D#7/Eb7 E7 F7 F#7/Gb7 G7 G#7/Ab7 A7 A#7/Bb7 B7 

MIDI Note Number 96 97 98 99 100 101 102 103 104 105 106 107 

Note Name C8                       

MIDI Note Number 108                       

Note: Due to different habits, some users will fall by one octave (that is, C4 = 48), please determine the MIDI notes 

according to your actual use. 

 

MIDI value & DMX value Table 

 MIDI to DMX coefficient: Coefficient = 2.01 (can be changed to other values). 

 The formula of MIDI value corresponding to DMX value is: MIDI value*2.01 = DMX value (ignore the data after the decimal point). 

 When the MIDI value range is 0~99, the DMX value is exactly twice the MIDI value 0~198. 

 When the MIDI value ranges from 100 to 127, the DMX value is twice the MIDI value+1 of 201 to 255. 

(Note: The MIDI value is MIDI note velocity value/MIDI CC controller value/MIDI aftertouch value, which is determined by the 

configured Sta parameter.) 

MIDI Value 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 

DMX Value 0 2 4 6 8 10 12 14 16 18 20 22 24 26 28 30 32 34 36 38 

MIDI Value 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 

DMX Value 40 42 44 46 48 50 52 54 56 58 60 62 64 66 68 70 72 74 76 78 

MIDI Value 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 

DMX Value 80 82 84 86 88 90 92 94 96 98 100 102 104 106 108 110 112 114 116 118 

MIDI Value 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 

DMX Value 120 122 124 126 128 130 132 134 136 138 140 142 144 146 148 150 152 154 156 158 

MIDI Value 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 

DMX Value 160 162 164 166 168 170 172 174 176 178 180 182 184 186 188 190 192 194 196 198 

MIDI Value 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 

DMX Value 201 203 205 207 209 211 213 215 217 219 221 223 225 227 229 231 233 235 237 239 

MIDI Value 120 121 122 123 124 125 126 127                         

DMX Value 241 243 245 247 249 251 253 255                         



 

4.4. Upload/download configuration parameters 

Users can configure MIDI to DMX parameters according to different application scenarios. And save the 

configured parameters as a file for quick configuration next time. 

 Preparation 

Operating environment: Windows7 or above system. 

Software: Download the "AccessPort.exe" software. (Download from www.doremidi.cn) 

Connection: Connect the USB Device port of MTD-1024 to the computer. 

 Configuring the COM port 

Open the "AccessPort.exe" software, select "Monitor→Ports→COMxx", as shown in the figure: 

(Note: The COM names of different computers are different, please choose according to the actual situation.) 

 

Select "Tools→Configuration", as shown in the figure: 

 
Select "General", configure COM port parameters and click "OK", as shown in the figure: 

http://www.doremidi.cn/


 

 

 Upload configuration parameters 

Enter "upload request" in the software, click "Send", and you will receive "...end of data." as shown in the 

figure: 

❶ ❷

❸

 
  



 

Click "Save" to save the data as a .txt file, as shown in the figure: 

 

 

 Download configuration parameters 

Select "Transfer File→Select File→Send", and receive "download success." after sending successfully, as 

shown in the figure: 

❶

❷

❸

❹

 

  



 

5. Precautions 

1) This product contains a circuit board. 

2) Rain or immersion in water will cause the product to malfunction. 

3) Do not heat, press, or damage internal components. 

4) Non-professional maintenance personnel shall not disassemble the product. 

5) If the product is disassembled or damaged by improper use, the warranty is not available. 

 

6. Questions & Answers 

1) Question: The USB Device port cannot connect to the phone. 

Answer: Please confirm whether the mobile phone has the OTG function first, and it has been turned on. 

2) Question: The USB Device port cannot be connected to the computer. 

Answer: 

 After confirming the connection, whether the screen displays "USB Connected". 

 Confirm whether the computer has a MIDI driver. Generally speaking, the computer comes with a MIDI driver. 

If you find that the computer does not have a MIDI driver, you need to install the MIDI driver. The installation 

method: https://windowsreport.com/install-midi-drivers- pc/ 

3) Question: MIDI IN does not work properly 

Answer: Make sure the "MIDI IN" port of the product is connected to the "MIDI OUT" port of the instrument. 

4) Question: "AccessPort.exe" software cannot find the COM port. 

Answer: 

 Please confirm that the USB Device port of MTD-1024 has been connected to the computer, and MTD-1024 

has been powered. 

 Please try to connect to another USB port of the computer. 

 Please select another COM port in the "AccessPort.exe" software. 

 Please try to install the USB COM driver. Virtual COM Port Driver V1.5.0.zip 

 

 

 

If it cannot be resolved, please contact customer service. 

 

 

 

 

 

Manufacturer: Shenzhen Huashi Technology Co., Ltd. 

Address: Room 910, Jiayu Building, Hongxing Community, Songgang Street, Baoan District, Shenzhen, 

Guangdong, China 

Post Code: 518105 

Customer Service Email: info@doremidi.cn 

https://windowsreport.com/install-midi-drivers-%20pc/

